Accidentally deleted .bin file and unable to connect through USB / BLE Mini


#1

Hi,

As I was trying to update my .bin file in my BLE mini, I deleted the old file just as user guide tells me.
However, at the moment I deleted the .bin file, my mini started to reboot. No matter I pushed the button or not, when ever it connects to computer it will just keep rebooting. I also not able to paste new .bin file into it cuz it keep rebooting.

What should I do to recover it?

Does anyone have this problem before?

Thanks!


#2

Hi,

Since the board is old, you need to use Windows 7 for firmware upgrade via the USB port.

Do you have a Windows 7 PC?


#3

Hi Cheong,

Yes, my problem is very similar to this article, and I tried everything in there.

The problem right now is that I can’t format the device because it keep reconnecting to my pc when it’s plugged in.

I also tried other people’s computer but the result is the same.

So I was thinking this is a hardware problem?


#4

Hi,

Can you please help me and tell me what should I do?

Thank you so much

Peter


#5

Did you try formatting the BLE Mini on Windows 7 machine?

If it is not working, then you may need to use this to recover the board.

If you have TI CC debugger, you can use it directly for your development.


#6

This happened to me upon plugging it into Windows 10. Looking to borrow a Windows 7 laptop from a buddy right now. Doing the CCLoader arduino flash seems plausible but the DD and DC pins are too tiny and have not been extended to anywhere easily accessible with standard wires. I’m going to leave that to a last resort option right now.