BLE Bootloader not advertising


#1

Hello,

currently i’m using the BLE Nano v2 and the DAPLink USB-Dongle. IDE is Eclipse with gcc and nrf5 SDK v14.2. My aim is to do an OTA DFU so I tried the bootloader_secure_ble example from the SDK following these steps: https://devzone.nordicsemi.com/b/blog/posts/getting-started-with-nordics-secure-dfu-bootloader
I’ve customised the leds_init() & buttons_init() function to match the onboard-LED and my connected button, updated the dfu_public_key.c file and flashed it together with the s132 softdevice v5.0 via drag and drop. I get into dfu mode by pressing the button on startup -> LED lights up. But there’s no advertising of “DFU Targ”.
Had anyone the same problem and can help me?

Thanks in advance
Markus


#2

Hi Markus,

i am running into exactly the same problem. Bootloader is also starting but no BLE advertising.
Did you find a solution by now?

kindly regards,
wenzel


#3

Sorry for my late reply.
To check if the device advertises as “DFU Targ”, I used the nrf Connect App for iOS on an iPad from nordic semiconductor. The App didn’t found the device. But when I used the Android version of the same App on an Google Pixel Tablet, the device got found.
It sounds a little bit strange but this “solved” the problem…
kind regards Markus