BLE controller won't detect my device


#1

when I press scan on my iPhone 6s on version 10.3.3 on the BLE controller app it says:

Error
No BLE Device found.

could someone help?


#2

Have you loaded the corresponding sketch to your BLE Nano yet?
BLEController, SimpleChat or SimpleControls.


#3

I tried but the code is pasted with errors that shouldn’t really exist


#4
'IS_PIN_DIGITAL' was not declared in this scope

if (IS_PIN_DIGITAL(pin)) {

#define IS_PIN_DIGITAL(p) ( (p) >= 2 && (p) < 22 )

same with TOTAL_PINS


#5

not example - I fixed and uploaded that and pressed scan and same problem, so again:

could someone help me please?

thanks in advance and for previous help.


#6

ok, a partial solution is to try a different example.


#7

Hi,
I have the exact same issue. Which example did you try out? (I tried BLE Controller, Simple Chat and Simple Controls…)


#8

just BLEcontroller (try completely deleting and reinstalling only the necessary stuff in the 1.8.0 idle (allowed me to use simple chat and simple controls but I still need BLEcontroller - see my other string, the BLEcontroller example doesn’t work.).

thanks for reading this string


#9

Is there anyone who resolved this issue?
I tried all the BLE example inside the library but my BLE Nano2 never connected to my android phone.
Only the precompiled sketches worked fine