BLE NANO 2 nRF52832


#1

Hello
I’m sorry about my English

I bought the next product from spark fun - “RedBearLab BLE Nano v2 - nRF52832 no headers”
I install the nRF52 Board Package to arduino environment and try to connect to arduino uno.

vdd - 3.3V
sda0 - Pin A5
scl0 - Pin A4
gnd - gnd
the led is blink and i load the “i2c_scanner” i run the sketch and i get “no device found”

I tried to search the net about how the product works with Arduino, I found nothing.

can i get help
eli


#2

Update:
I try to scan the ble from my Microsoft mobile to pair the devices , the Bluetooth found

eli


#3

hi elivb
actually, the board provides the developing way just the same as Arduino and you can find nRF52 and follow the guide in docs to have a try first. etc blink the light


#4

Hello Lucian
Thanks for your response, I know the library but the nRF52832 is Soc I want to upload sketch to arduino, In other words, I want to program the module through Arduino so I connect the module by i2c.
I tried to search the net about how to do it but without success.

I’m be happy to get help
eli