BLE Nano Kit v2 Issues (MB-N2)


#1

I have two Nano Kit v2 boards for evaluation. So far the experience has been honestly pretty disappointing. I have followed various guides, all referenced by RedBear documentation, for setting up the Arduino IDE and mbed and cannot even get any examples to work. Blinky, BLE Beacon, HRM examples… No beans. The sketches seem to upload just fine, but do not appear to be running.

I have verified that the firmware on both boards is updated to the most recent DAPLINK v1.5. My machine is running Windows 10.

Any help would be much appreciated. As the end goal is to interface these modules with another microcontroller in communication with other sensors, we may switch to a different solution if we cannot get this working. Please help!!


#2

same, pls just provide a confirmation that it doesn’t work so at least i have an explanation.


#3

Thank you for replying, jeslynlame. if I understand correctly, you are also having trouble getting the Nano 2 up and running? Which sites or tutorials have you used?

I am really troubled by the fact that another customer experiencing difficulties has commented before Red Bear support has; in fact, I am unsure that I have seen an official Red Bear post on this forum.


#4

Hello kschwayb, yes i am facing trouble getting it to work with arduino, i was able to do drag and drop.

I feel odd too because i need it to work, and its not working which is quite f-ed up. i tried all methods, and i am SURE SURE SURE that all my settings are right, u can check the post i made recently.


#5

I have not had any success on Arduino or Mbed either. None of their supposed examples work, and Mbed doesn’t even technically support the nano 2.

I have had success with Keil uVision. It has taken around 30 hours of reading documentations and things like that, but I finally have the light blinking.


#6

I can’t upload from Arduino 1.8.5 (Windows 10 64-bit) to Nano Kit v2. Drag and drop of pre-compiled examples to DAPLINK works.

I’ve added a ME TOO reply to jeslynlame’s post here:

Hope there’s a solution soon…


#7

RBL support just had me burn the boot loader (Arduino IDE Tools -> Burn Bootloader) and everything now works!


#8

Hi digsub,

I followed the same procedure (bootloader burning). Now I’m able to upload the simple blink sketch and see the serial monitor, but every time I upload the sketch the error persist


#9

Hey @jbooth ! Could you tell me how did you make nano v2 work with Keil?

None of the examples I’ve tried (included blink example) worked after I download them to flash memory, although they’ve compiled with neither errors nor warnings.

I’m using Keil 5.24 with SDK 14.2.0 and my BLE Nano v2.0 comes with a DAPLink v1.5

I hope someone has more effective instructions then the ones at https://github.com/redbear/nRF5x because none of them helped me.

It would be helpful if someone have any tip about using arm-gcc too (same symptoms as using Keil)

Thanks in advance


#10

Hey @adonay!

I will be honest with you, working with Keil is very painful when compared to Arduino. The benefits that you get come with the access to their PPI drivers that let you schedule different hardware tasks and events to be performed without taking up processing time. If what you are developing needs the extra power that comes with the Nordic SDK then go for it, but if you are able to get away with Arduino then you should definitely save yourself the headache.

That being said, I have not been able to get the DAPLink to work successfully with Keil. I purchased a SEGGER J-LINK EDU Mini (like here) in order to successfully program the board. Then I worked my way through the Tutorials on the Nordic Website (here) and after a lot of pain and suffering I was able to write basic code. (Keep in mind I do not have a very strong background in embedded programming so everything there was new to me)

A few weeks after I learned how to use Keil with the Nordic SDK, I saw the posts on this page that said how to get everything to work with Arduino. And I much prefer to write code (especially code for the BLE part) in Arduino if I can get away with it.

I hope this helps!