BLE Nano Kit v2 with Arduino 1.8.4 samples doesn't work


#1

Hi,

It seems BLE Nano 2’s examples doesn’t work with Arduino 1.8.4 IDE (on windows and ubuntu 16.04 x64)

I set preferences’s Additional URL: https://redbear.github.io/arduino/package_redbear_nRF5x_index.json

I choose board manager -> nRF52832 0.0.2 
I choose board BLE_Nano2
Port on Windows COM5
Programmer: RBL_DAPLink
But when I compile any BLE_HRM example, it doesn't work on board.

I also built Blink example from Basic, by adding #define LED_BUILTIN 13
(or D13)

It seems it compiles .hex, but no LED blinking on board. Even if I just compile & copy .hex to x:/daplink, it seems it load it but fails.
-> on Ubuntu 16.04 x64 I have similar results.


I tried then compile .hex package on https://os.mbed.com 's compile, and I got the blinking working from mped’s compiler

#include "mbed.h"

DigitalOut myled(P0_11);

 int main() {
    while(1) {
        myled = 1;
        wait(10);
        myled = 0;
        wait(1);
     }
}

-> And blinking is fine.
But arduino 1.8.4 compiling always fail.


Pre-compiled nRF52_HRM.hex from https://github.com/redbear/nRF5x/tree/master/nRF52832/test
-> this works fine.


#2

You use different tools if you want to program with mbed, not the Arduino IDE.

Please refer to our mbed suer guide.
https://github.com/redbear/nRF5x/blob/master/nRF52832/docs/Mbed_IDE_User_Guide.md


#3

I know they are different tools, that’s why I explained what did work, and what did not work.

As I told, I got blinky working with mbed after doing some modifications, but not with Arduino IDE.
-> I would like to get Arduino working as well.

That MBed IDE user guide doesn’t work directly.

You need to change the line:
DigitalOut led1(LED1);
to ->
DigitalOut led1(P0_11);

to get it working, please check the examples and make them correctly working with clean installs.
-> This means, you take a clean windows, or clean ubuntu 16.04 x64 (or mbed web compiler), and make the installation and get the example working from the beginning. so you don’t have some extra libraries (or path values, or header defines) that may effect on compiling.


#4

For unknown reason, BT (HRM and Serial) and Blinky example(s) works with Arduino compiler now.
-> probably others works as well.

These didn’t work before for me before. And I didn’t even re-install arduino during this time. just re-tried them.
-> I am quite sure I did boot my windows before. So re-booting probably is not a reason.

But good for me that these works.