BLE NANO2 not working at all with sample apps


#1

I got BLE NANO 2 this week and tried to run sample apps - mbed_blinky, BLE_HeartRate, both fails in copy on DAP LINK folder on my Mac desktop…

I just copy and pate hex file to the DAP LINK folder, which was copying hex files for a while and suddenly stopped and disconnected folder, then re-connected DAP LINK folder.

Is there any wrong steps?
Please suggest.

I bought BLE nano 1 and failed the same manner.
I was suggested to buy BLE nano 2 and tested only to end up in fail.

So far both BLE nano and BLE nano2 does not work even sample apps.


#2

1.upgrading your DAPLink firmware.


2.Erase your BLE Nano2
nRF52_EraseChip.hex
3.Test your BLE Nano2
https://github.com/redbear/nRF5x/tree/master/test

Please try it!


#3

When programming is done the DAPlink folder will disappear and reappear. That’s the normal behavior.

If you are using hex files in nRF5 SDK examples, you need to recompile the files after changing board config header file to get the blinky working. BLE nano uses a pin different from the official nordic development board for LED.


#4

Excellent notice. Thank you for your clear steps, it worked for me.

So, i just spent my first 2 hours with my new BLE Nano Kit v2 (DAPLink v1.5 + BLE Nano v2.0). It took me this long just to figure out these 3 clean steps to setup and run the sample apps.

My mistake was that when I first inserted the kit into my usb port, i followed the old instructions shown on the youtube video “Tutorial: RedBear BLE Nano Quick Start with Arduino” which actually refer and apply ONLY to the v1.0 kits and, while i didn’t know, I pasted the ‘bootloader.hex’ onto my v2.0 kit. After this I was unable to detect my device using nRFToolbox’s HRM sample. As I figured out, I had to do exactly these 3 steps as mentioned by shun-gan. In detail i did:

  1. Remove my BLE Nano v2 kit from my computer.
  2. Click & hold the button (on the DAPLink v1.5 device) while inserting it into the computer’s USB port to enter Maintenance mode.
  3. Downloaded the file named ‘DAPLink_V1.5_Interface_nRF52_20170106.bin’.
  4. Dragged & dropped that file into the root directory of the Maintenance drive.
  5. LEDs went off & on again, Windows recognized the device now as DAPLINK and was kinda stuck at an “Installing Device…” window. If this shows up to you and does not close automatically, ignore it and go to step 6 straight ahead - no tears.
  6. Downloaded the file named ‘nRF52_EraseChip.hex’.
  7. Dragged & dropped that file into the root directory of the DAPLink drive.
  8. Device re-connects automatically. No worries.
  9. Downloaded the file ‘nRF52_HRM.hex’ from this nRF5x/test/ folder were the sample firmwares are located.
  10. Dragged & dropped like before.
  11. Used the nRFToolbox for BLE by nordic and tested the sample HRM app which always gives something like 10 bpm step up or down every second.

Wish this helped out any baffled beginner like me!
Now, let’s have fun!


#5

I think the test .hex files (for BLE Nano2) are at https://github.com/redbear/nRF5x/tree/master/nRF52832/test
Seem to work for me.


#6

My nano is stuck in maintenance I tried to flow your step but it keep in maintenance and unable to put it back in DAPLink


#7

Thanks a lot for your hints and steps… After a long struggle , we could make iour BLE Nano 2 kit work with this help. Thank you so much !! :slight_smile:


#8

None of this worked for me. Followed every instruction to the T. Everything I do, it takes a long time and then I just get a FAIL.TXT. I tried rewriting the DAPLink firmware, erasing the chip, testing multiple programs…nothing.

The BLE Nano 2 is terrible. If you are reading this and are considering it: Don’t.


#9

try it with Arduino or retry from start, because most people don’t suffer problems like these, so DO try it, it IS good, but understanding of Bluetooth, your chosen programming software and base coding knowledge also helps (I can code, my dad’s friend helps in base coding knowledge and I suck at Bluetooth which is why I’m so active here. but BLE = GOOD

:grinning: