Blend v2.0


#1

Hi,

I have some RedBear Blend V2.0 and I´m experiencing some problems to load software to BLEND.
The software I´m using is working properly in RedBear V1.0
I´m looking for a solution in GITHUB but I’m not sure what to do.
Could you help me?
Thanks in advance.
Here is the message:
C:\Users\João\Documents\Arduino\libraries\arduino_30192\src/nRF51822.h:15:30: fatal error: s110/ble_gatts.h: No such file or directory

#include <s110/ble_gatts.h>

I Know a library is missing, <s110/ble_gatts.h> but i can´´t find it to install

Thanks in advance.
João Rocha


#2

Hi @joao-rocha,

If you are using the Blend v2.0, I would suggest you to install the board package as instructed here:

If conflicts raised during compiling after you installed the board package, try removing the previously installed BLE libraries.

Best regards,
Guohui


#3

Hi,

Thank you for your support.
It solved the problem.

Best regards,

João Rocha


#4

Hi Guohui,

I have some problems with the BLEPeripheral.h library and BLEND V2.0
I am not sure if this pins are correct:
#define BLE_REQ 9
#define BLE_RDY 8

I can not write in my Android APP. However everything appears to work…

Could you help me?

Best Regards,
João Rocha


#5

Hi @joao-rocha,

I am pretty sure that there are no BLE_REQ and BLE_RDY for Blend 2.0. Maybe we are talking about a different board? Is your Blend 2.0 based on nRF52832? Could you please post the relative path to the BLEPeripheral.h? I’m afraid that you are referring to the BLE library for nRF8001, while your sketch actually refers to the library for nRF52832. That makes sense why it appears to work.

Best regards,
Guohui


#6

Hi Guohui,

thank you.
You’re right. I am using the old library. I’ll fix it.

best Regards,

joao rocha