BlendMicro not detectable by Redbear controller App?


#1

Hi,

Purchased BlendMicro and was able to see some BlE packets coming on the app, through the numbers were very low. then I made a hard reset of the .board after words it all came down to 0. the restarted note Application and BLE was not detected ever since. Did I tried something wrong? I do not understand .


#2

I don’t quite understand what happens on the BLE Controller App, since it seams like the App doesn’t present this data.


#3

Hi,

I mean i can see the Rssi value and the Ble device found. But lately i was not able to find anything. any help here is appreciated!!


#4

Have you uploaded any sketch? Try uploading the BLE Controller sketch and re-entering the App.


#5

IS it sketch based? this is not the default functionality to throw BLE apckets?


#6

Yes. Actually, the BlendMicro is the combo of ATMEGA32U4 and nRF8001 BLE chip. Just play with it as an Arduino compatible development board. And install the BLE library to play with the BLE.


#7

Hey thanks, I am gonna try this . I am sure we can use both Atmega32 functionality[Emulation] and BLE at the same time ?


#8

Of course. Image that the BLE chip is a SPI device hanging on Atmega32u4.


#9

I am trying it now .Still the app does not show any BLE device .
I added BLE controller sketch . No success.
Then BLE Broadcast sketch . I do see some BLE packets on some other Application , but now sure if Blend is sending them and these packets are also very slow rate .

How can I move forward here ?


#10

Please follow this guide to get started first.


#11

Hi It seems I m having a hard time with this module . I am not able to get blend micro boards in boards menu . I tried manually replacing main.cpp from blend folder into folder mentioned in Windows/OSx . After restarting I never see those boards . My biggest problem remains the non functional BLE . though I am able to upload sketches and even tried a Keyboard emulation program that worked fine for me . but I do not see any device found in BLEController App after uploading BLE controller Sketch. I am not a newBie , have already worked with many BLE/BT modules. this board is making me nuts . Help here .


#12

Hi @navaljosh,

Sorry for suffering from getting started with the BlendMicro. Please follow the instructions below to install the board package and BLE libraries:

  1. Remove/Uninstall the board package and the BLE libraries.

  2. Start the Arduino IDE. Navigate to “File > Preferences”, fill the “Additional Boards Manage URLs” with https://redbearlab.github.io/arduino/package_redbearlab_index.json.

  3. Navigate to “Tools > Board > Boards Manager…”, install the “RedBearf AVR Boards” package. If installed successfully, you will see the BlendMicro listing under the “Tools > Board”.

  4. Download the ble-sdk-arduino and nRF8001 zipped libraries.

  5. Navigate to “Sketch > Include Library > Add .ZIP Library”. Navigate to where you download the zipped files and select the nRF8001-master.zip to import.

  6. Navigate to “File > Preferences”, remember the path that showed under the “Sketchbook location”. And then navigate to the path, you will see the libraries folder. Unzip the ble-sdk-arduino-master.zip and copy the BLE folder, whihc is under the “ble-sdk-arduino-master\libraries”, to the libraries folder. Now you should see that both of the BLE and nRF8001-master under the libraries folder.

  7. Navigate to “File > Examples > RBL_nRF8001”, select the BLEControllerSketch and upload it to BlendMicro(of course you must select the BlendMicro under “Tools>Board” first).

  8. Use the BLEController App to play with it.

NOTE: the examples under “File > Examples > BLE” might not work, since some of them are not for BlendMicro.

Regards,
guohui


Can i use BLE Shield in place of HM10 module?
#13

Yes that was the step missing !! thanks a ton .
Do we have any examples for Connecting to another BT device using its MAC id from blend Micro?


#14

It won’t work. The nRF8001 chip can act as BLE peripheral only, i.e., it is always the device to be connected by other BLE central device.