Bluetooth & Shutdown problems


#1

I’m using NOOBS 1.9.2 on a v1.2 Pi Zero.

I’ve got the wifi working. That’s fine.

Bluetooth. I edited the hciuart.service file as instructed, but although the Bluetooth icon is blue on the desktop, when I click the make visible tab, the symbol flashes green, but nothing happens.

And when I click the add device tab, the window opens, but again nothing happens.

I have my mobile phone (Nokia 301) with bluetooth switched on and set to visible, but the pi cannot detect it, and it cannot detect any nearby Bluetooth devices.

So that’s problem number one.

Number two.

When shutting down the pi, with the redbear board attached, it cannot shut down properly and says that the system shut down is tainted.

Here’s a photo from the TV of what appears on screen. The screen is frozen at this point.

Shutting down the Pi without the redbear attached, and it closes down properly.


#2

I’m having the same BT problem. I’ve tried 2 different IoT pHats and so I think it’s SW or compatibility with the old Zero boards…

I’m also using a v1.2 Pi Zero.


#3

I spoke to a couple of guys I work with, and when I said Kernal Panic, neither offered a solution, but both laughed and said they hadn’t seen that happen in years.

I take it this is not a good thing?


#4

Hi,

We are looking into this issue now, will get back to you as soon as possible.


#5

I am seeing the same problem - kernel panic on shutdown. Pi zero 1.2


#6

Same problem with Pi zero V 1.3 an V 1.2. I’ve tested both Pis with a clean install of NOOBs 1.9.2
Wifi works flawless but on every shutdown I see a kernel panic


#7

I am also getting a kernel panic on shutdown RPi Zero 1.3. with IoT pHAT attached.

uname -a:
Linux rpi-xx 4.4.13+ #894 Mon Jun 13 12:43:26 BST 2016 armv6l GNU/Linux


#8

I’ve the same panic recognized and what’s strange is that with a bare RasPi-Zero (V1.3) the PWR LED got OFF vs the pHAT connected one it stays ON.


#9

I am not sure they will fix this soon or not.


#10

Also getting kernel panic on shutdown, was trying to use a Mausberrycircuits switch to turn on/off pi, after installing setup.sh, raspbian tries to load but goes to kernel panic. Will there be a solution soon?.


#11

The same with pi zero v1,2. Any solution?


#12

Well, it’s four months later.

Has anyone come up with a solution for the kernel panic?


#13

I sure would like to hear about the status of this bug (kernel panic on shutdown) as well as whether it’s “merely cosmetic” or a potential sd card corrupter. Are we not hearing anything because it’s unfixable? Hate to think I bought three of them for nothing!


#14

I’d just like to add that I am encountering the same exact issue using an RPi Zero v1.3. I saw this when I started using the IoT pHat yesterday.

Fingers crossed that folks at Redbear see all of us here and push out an update.


#15

Hi all,

EEPROM firmware v0.4 will fix this, so stay tuned.


#16

I just installed the v0.4 firmware, rebooted and shutdown. FIXED, thanks team!


#17

Okay, so six months later…

When I remember where I put my iot phat, how do I install this update?


#18

Please follow this to update it:


#19

After following the update instructions for iot Phat 0.3. to version 0.4
the cat /proc/device-tree/hat/product does not show the update?

Still says v0.3:
[email protected]:~ $ cat /proc/device-tree/hat/product
IoT pHAT w/[email protected]:~ $

I did run it following the 0.4 install instructions?


#20

I tested again and it works fine, please try again with these steps:

Download the EEPROM and script files (do this inside your RPi if you have WiFi connected already),

$ wget https://raw.githubusercontent.com/redbear/IoT_pHAT/master/eeprom/experimental/v0.4/IoT_pHAT-with-dt.eep

$ wget https://raw.githubusercontent.com/redbear/IoT_pHAT/master/eeprom/experimental/v0.4/eepflash.sh

Change the flash tool mode to executable,

$ chmod +x eepflash.sh

If you just want to write the compiled configuration file

Step 1 - Use this command to burn, answer yes:

$ sudo ./eepflash.sh -f=IoT_pHAT-with-dt.eep -t=24c32 -w

Step 2 - Reboot

$ sudo reboot