Discussion Forums

Can not get the device to go into DFU mode

#1

I have tried at correct SETUP and RESET holds and I can not get the board to flash yellow. Version 2.1.

Any suggestions or is my board bad?

Russ

#2

Hi @russel2512, kindly refer to

If you can not get any color flashing when holding the SETUP button after reset, you can hold the SETUP button for 3 seconds when Duo is running application to enter listening mode, i.e. blinking blue, to check if the SETUP button is bad or not.

Have a good luck! :blush:

#3

When I hold SETUP down, I get the blue flashing led. When I hold both down, it stops flashing, no matter how long I hold them both down. The led above RESET glows a faint blue.

#4

Fixed my issue. I went to the Particle site and found the correct method to put it in DFU mode. Updated firmware ok.

#5

I’ve scanned through the above, but I can’t seem to even get my RedBear Duo to enter DFU mode. I’ve tried both my laptop usb and a power pack.

See the attached video:https://youtu.be/s9_RiPvJ_BU 1. (someone has told me about the anti-static stuff)

I am definitely holding both, then release reset, then holding setup for over 30s…

Also in this state I can’t connect to it via the serial connection, and I am yet to claim it on the Particle cloud.

Am I missing something fundamental here?

Cheers

(Apologies for the audio - yes it is “The Last Samurai” - Soundtrack Suite (Hans Zimmer))

#6

Here are two more videos showing the reset process again

#7

Apologies but this will be the least comprehensive resolution steps ever.

  1. Managed to get the things to reset and wipe wifi credentials by holding and the rest and setup buttons until blue light came back.
  2. In this state I checked thje firmware and both devices were on 0.3.1, whereas the latest firmware is 0.3.3

On to DFU mode…

  1. I had to unplug the device from my laptop USB. Using a power bank I had to hold both buttons down with a pair of wooden chopsticks then plug in the power bank.
  2. Releasing the reset button but not setup I found that I was able to get it into DFU mode… Finally…
  3. Once achieved on the power bank I switched back to the usb ports on my laptop and repeated the step 4…
  4. I checked the connection through the serial montior in the arduino IDE and used the IDE environment to run the burner which updated the firmware.

Now they both finally work and are connected to the Particle Cloud…