Can't Program Nano v1.5 with DAPlink v1.5


#1

Hi,
I use both Nano V1.5 and the new Nano 2. The DAPlink V1.5 that came with the Nano 2 works fine for programming the Nano 2, but Fails when I use it to try to program my Nano V1.5. Is the DAPlink V1.5 compatible with the previous generation Nanos? My DAPlink firmware version is “DAPLink_F103_BLENano.bin”

Thanks

By the way, I did verify that I can program my Nano V1.5 with my older DAPlink V1.0 board, but when I use the new DAPlink V1.5 to load exactly the same .hex file, it fails.


#2

Hi kmoto,
I have the same issue, have you resolve this?
Any comment will be very grateful!

 Thanks!

#3

You need different firmware on DAPLink (any version) for Nano v1.5.
https://github.com/redbear/nRF5x/blob/master/nRF52832/docs/Mbed_IDE_User_Guide.md

For using with Nano v2
https://github.com/redbear/nRF5x/tree/master/nRF52832/daplink


#4

Thanks Chi. Before I posted the question I did try to load some versions of the nRF51 series firmware onto the DAPlink, but it kept ending with a “fail” message. But after your post I scoured the GitHub again and found a version I had not tried yet. And It worked! Specifically, the firmware that worked is called “gd32f103cb_rblnano_if_crc_legacy_0x8000_20161130.bin” and I got it from:
https://github.com/redbear/nRF5x/tree/master/nRF51822/daplink/F103-DAPLink/board_v1.5


#5

Great kmoto thanks! it works for me too!


#6

Hi Kmoto,
I have the same issue.
how do I flash the .bin file into the DAPlink v1.5?

Thanks,
Danny