Connecting using USB on linux


#1

I’ve been able to set up my redbear duo and get particle working with firmware 0.3.1.

I’ve been working through a tutorial which requires me to connect the device to my laptop.

Similar to the out of box experience instructions for connecting via USB I’ve tried
ls /dev/tty.*
and nothing shows up.

I’ve tried resetting to factory defaults and following all the steps for out of box usb connection to that point and it still doesn’t work.

I’ve tried 3 different USB cables.

I’ve also tried the instructions for using dfu-util to flash firmware, hoping that I could at least get the device to show up using
dfu-util -l
but that also shows nothing.


#2

Did you put the Duo into DFU mode before you listing available device using dfu-util -l?

Did the Duo show up on Windows?


#3

Mine usually shows up as ttyacm0 (or something like that). Try searching tty* instead of tty.* – leave out the dot. Also, your account needs to be a member of the dialout group (again, IIRC…). Someone please correct me if I got that wrong. Good luck!


#4

Yes and no.
//////////////////////////////////////


#5

Output from ls /dev/tty*:

/dev/tty /dev/tty23 /dev/tty39 /dev/tty54 /dev/ttyS11 /dev/ttyS27
/dev/tty0 /dev/tty24 /dev/tty4 /dev/tty55 /dev/ttyS12 /dev/ttyS28
/dev/tty1 /dev/tty25 /dev/tty40 /dev/tty56 /dev/ttyS13 /dev/ttyS29
/dev/tty10 /dev/tty26 /dev/tty41 /dev/tty57 /dev/ttyS14 /dev/ttyS3
/dev/tty11 /dev/tty27 /dev/tty42 /dev/tty58 /dev/ttyS15 /dev/ttyS30
/dev/tty12 /dev/tty28 /dev/tty43 /dev/tty59 /dev/ttyS16 /dev/ttyS31
/dev/tty13 /dev/tty29 /dev/tty44 /dev/tty6 /dev/ttyS17 /dev/ttyS4
/dev/tty14 /dev/tty3 /dev/tty45 /dev/tty60 /dev/ttyS18 /dev/ttyS5
/dev/tty15 /dev/tty30 /dev/tty46 /dev/tty61 /dev/ttyS19 /dev/ttyS6
/dev/tty16 /dev/tty31 /dev/tty47 /dev/tty62 /dev/ttyS2 /dev/ttyS7
/dev/tty17 /dev/tty32 /dev/tty48 /dev/tty63 /dev/ttyS20 /dev/ttyS8
/dev/tty18 /dev/tty33 /dev/tty49 /dev/tty7 /dev/ttyS21 /dev/ttyS9
/dev/tty19 /dev/tty34 /dev/tty5 /dev/tty8 /dev/ttyS22
/dev/tty2 /dev/tty35 /dev/tty50 /dev/tty9 /dev/ttyS23
/dev/tty20 /dev/tty36 /dev/tty51 /dev/ttyS0 /dev/ttyS24
/dev/tty21 /dev/tty37 /dev/tty52 /dev/ttyS1 /dev/ttyS25
/dev/tty22 /dev/tty38 /dev/tty53 /dev/ttyS10 /dev/ttyS26

Is there a way to add myself to the dialout group?


#6

Any obvious behavior after powering up the Duo? Since you had once worked well with the Duo, before you operating the Duo by following that tutorial, it should show up as a libusb device when it is in the DFU mode. So what have you done to the Duo after that?


#7

When I set up the device I used the mobile app to set it up, so I’ve only used the USB for power so far.


#8

How did you update the system firmware to v0.3.1?


#9

Using particle.


#10

That’s odd. Please contact [email protected] for further customer service。

Best regards,
Guohui