Cortex_M Reset Issue Causes Failure to Upload


#1

Hi,

I’ve been using the BLE Nano v2 for the past several weeks using the DAPLINK v1.0. Suddenly, my arduino sketches fail to compile, and it is giving me the following error:
Open On-Chip Debugger 0.10.0-dev-00254-g696fc0a (2016-04-10-10:13)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 1
adapter speed: 10000 kHz
cortex_m reset_config sysresetreq
in procedure ‘init’
in procedure ‘ocd_bouncer’

An error occurred while uploading the sketch

I have re-installing the daplink 1.0 .bin file onto the daplink, I have also tried uploading the .hex files, but those won’t upload either(gives me the same error). I should also mention that the device heats up, not severely, but a noticeable amount more than usual. What concerns me is that this wasn’t caused by me, since this phenomina came out of no where when I was compiling a revision of an arduino sketch I made.

Does anyone have any suggestions or options that I could take to figure out how to fix it?

Thanks


#2

You can try burning the bootloader and see you f that works.
From Arduino IDE, select it , use RBL daplink as the programmer.
Enabling load verbose , under preferences may show more info if you pass the connection problem.


#3

Thanks for the response.
I’ve tried burning the bootloader, I get the same error message. And the error message I gave was already with verbose output.
Any ideas?


#4

You can try to reload the bootloader on the DAPlink as well.
You press the reset button before plugging it in.
It will come up in bootloader mode, drag and drop its bootloader.
There is a document somewhere for it.


#5

You mean updating the interface firmware? I’ve tried reloading the .bin file for v1.0 DAPLINK board (For reference, https://github.com/redbear/nRF5x/tree/develop/nRF52832/daplink). The board excepted the upload, in so far as it flashed meaning it was uploaded, but it didn’t solve the problem.


#6

Yes, the interface firmware. If you have correct firmware version then I assume it would work, at least the bootloader upload would.
You may have hardware problem somewhere.
Sorry, I have no other ideas.


#7

Thanks for the advice.
I’d figured as much, but I just wanted to be sure there was nothing else I could try to fix the problem before I have to contact redbear.


#8

Hi @jj1,

Did you connect the DAPLink to the USB 3.0 port?


#9

Yes. I was using the same port on my computer, and I made sure that if I changed ports, I set the correct com port before I uploaded in the arduino IDE.


#10

I’d suggest you to try connecting the DAPLink to a USB2.0 port. Hope it helps.


#11

I tried using USB2.0, still nothing. I don’t think it is a port issue because the nanoV2 was uploading code just fine, it just stopped working when I tried to upload code a minute later. I didn’t change the port during the process. Any other ideas, I myself am grasping at straws here?


#12

Is the nRF52832 module warm to the touch, or so hot that you can’t leave your finger on it? What about the STM32 device on the DAPlink board; is it warm/hot?

Does the nRF52832 correctly run the last sketch you had successfully uploaded before you got the current error?

On my DAPlinkv1.0 + nRF52832 module, it does not feel warm on either of the devices. I wonder if one of the devices on your board burned up.


#13

Have you tryed the RBL-DAPlink…thats what I use with the nano2.


#14

Yes, I’m using the RBL-DAPLINK v1.0. Yes, the device gets warm. Not hot, but noticeably warmer than usual, enough to indicate that the device isn’t working properly. This is the primary reason why I suspect it might be a hardware issue. And yes, the sketches before uploaded perfectly fine before I go the current error.


#15

I mean when you power on the NanoV2, do you see the NanoV2 advertising, or doing whatever it was programmed to do, prior to the current error? Because even if you can’t program it now, the NanoV2 will save in the Flash storage its last successful sketch upload, and execute that when it powers on.


#16

Oh, I see what you are saying. No, the device does not advertise or function properly at all when I power it on and transmit. It just heats up