Daplink 1.5 failing to update firmware


#1

I’m having issues with my daplink 1.5 that came with my blenano v2

I recently tried to erase the chip and that came back with a fail.txt containing
“The transfer timed out.”
This also happens when I try to update the DAPLink_V1.5_Interface_nRF52_20170106.bin via maintenance mode
Loading any hex file to the blenano gets a fail.txt
Loading hex via arduino ide works to a degree, the device will have serial communications e.g the simple chat example stating it is advertising however no TXRX service is picked up on the android app or any device found on a scan via nrf connect.

I have also tried burning the boot loader via arduino ide which appears successful.

I have only once had keil uvision flashing the device, all other times nrfjprog reports no debugger connected. The CMSIS-DAP is selected as the debugger with the appropriate SW mode and algorithims and ram available. I tried to upload your bootloader for DFU at that time.


#2

Hi, what is the message inside the fail.txt?


#3

The transfer timed out


#4

If you load a test like the supplied hrm hex it says
An error occurred.


#5

yeah it shows me problem aswell! Its not fixer yet?! really want to deal with this now that i have time (sitting at home doing nothing but taking human growth hormone as my doctor recommended), so in the meantime i do nothing would want to fix the problem.


#6

Try enter to the maintenance mode and load the correct interface back to the DAPLink USB dongle.