DAPLink V1.0 cannot be recognized by Win7


#1

I just bought a BLE Nano with MK20(DAPLink V1.0). But my Win7 cannot recognize it as a “MBED” usb disk. The same computer with Ubuntu 14.04 can detect it as a “MBED” USB disk in the same USB port.

This is the lsusb in Ubuntu. “Bus 003 Device 004: ID 0d28:0204 NXP LPC1768”.

Attached image shows Win7 cannot get VID&PID.


#2

Hi johnnylee,
You need to install mbed driver on windows 7.


#3

Hi Jixing,
Did you mean the “mbedWinSerial_16466.exe” downloaded from “https://developer.mbed.org/handbook/Windows-serial-configuration”? It cannot be installed and says


#4

Hi johnnylee,
When installing the mbed driver, you need to connect DAPLink to PC.


#5

Hi JiXing,

Of course, I plug the DAPLink to my laptop before executing the “mbedWinSerial_16466.exe”.

I wonder there is compatibility issue with Win7 since the DAPLink device VID and PID are both 0x0000. Even if a special USB device driver not installed, the USB device still can provide correct VID and PID to host. But the DAPLink just provide 0x0000.


#6

Hi,

Would you mind to take a photo to show the PCB version?

For the DAPLink firmware, it should show “DAPLink” rather than “MBED” as the drive name.


#7

Please take a look at:


#8

Hi Cheong,

Mine is “DAPLink 1.0” displayed in the last one of the “https://github.com/RedBearLab/BLENano/blob/master/USB-IF/interface.jpg”.

Since Win7 cannot detect it, I don’t know the exact name it will show. Following message is captured from Ubuntu16.06.

[11975.252018] usb 3-1: new full-speed USB device number 2 using uhci_hcd
[11975.784015] usb 3-1: device descriptor read/64, error -71
[11976.008015] usb 3-1: device descriptor read/64, error -71
[11976.224015] usb 3-1: new full-speed USB device number 3 using uhci_hcd
[11976.363053] usb 3-1: not running at top speed; connect to a high speed hub
[11976.394055] usb 3-1: New USB device found, idVendor=0d28, idProduct=0204
[11976.394059] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[11976.394063] usb 3-1: Product: DAPLink CMSIS-DAP
[11976.394066] usb 3-1: Manufacturer: ARM
[11976.394069] usb 3-1: SerialNumber: 10950000066eff505050677267041426a5a5a5a597969904
[11976.400112] usb-storage 3-1:1.0: USB Mass Storage device detected
[11976.400285] scsi host6: usb-storage 3-1:1.0
[11976.430821] cdc_acm 3-1:1.1: ttyACM0: USB ACM device
[11976.432848] usbcore: registered new interface driver cdc_acm
[11976.432851] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[11976.439051] hidraw: raw HID events driver © Jiri Kosina
[11976.453288] usbcore: registered new interface driver usbhid
[11976.453291] usbhid: USB HID core driver
[11976.468818] hid-generic 0003:0D28:0204.0001: hiddev0,hidraw0: USB HID v1.00 Device [ARM DAPLink CMSIS-DAP] on usb-0000:00:1d.1-1/input3
[11977.404089] scsi 6:0:0:0: Direct-Access MBED VFS 0.1 PQ: 0 ANSI: 2
[11977.406117] sd 6:0:0:0: Attached scsi generic sg5 type 0
[11977.413094] sd 6:0:0:0: [sdf] 131200 512-byte logical blocks: (67.2 MB/64.1 MiB)
[11977.416079] sd 6:0:0:0: [sdf] Write Protect is off
[11977.416084] sd 6:0:0:0: [sdf] Mode Sense: 03 00 00 00
[11977.419077] sd 6:0:0:0: [sdf] No Caching mode page found
[11977.419083] sd 6:0:0:0: [sdf] Assuming drive cache: write through
[11977.478080] sd 6:0:0:0: [sdf] Attached SCSI removable disk


#9

I’m experiencing exactly the same issue.


#10

Hi @johnnylee,

Sorry for missing your post. Does it work for you now?


#11

It still not working with my Win7.


#12

I read the Linux log, it looks just fine, do you see there is a DAPLink drive on Linux?


#13

No. It seems being enumerated as a standard USB mass storage device class on Linux.


#14

Can you try using the following command to see the USB devices?

$ lsusb


#15

Bus 003 Device 003: ID 0d28:0204 NXP LPC1768


#16

The device ID is correct under Linux.

Do you have a chance to try with another PC?


#17

Hi, I encounter the same issue. It seems the DAPLink power up time is too long. so when win7 tries to comunicate with it, the DAPLink is still in initialization, and so will not response. Then when its actually ready, win7 already terminates the connection.

Currently the only workaround i use is to plug the DAP link partially (to make sure its properly powered first) then fully push it to USB port to start conection.

PS : I also Tried in Mac and this issue did not exist. Seems like the driver in windows need some modification or the hardware need to be fixed.

Hope it helps.


#18

Hi,

I am facing the exact same issue with my windows 7. Has any one found its solution?

Kind Regards,
Hassaan


#19

Hello,
I’ve exactly the same issue with Windows7 Pro 64. Is there any solution?

Best regards


#20

This worked for me, thanks alfian