Development w/ mbed


#1

mbed doesn’t yet recognize BLE Nano v2. I suppose that’s to be addressed soon?


#2

Hi boneskull,
Very sorry for this.
We are working with mbed to solve this。
Now you can use nRF52832 platform for BLE Nano v2.


#3

Is there an update for this? I’d like to have the blenano2 as a target in the online mbed compiler.


#4

Not sure what’s going on here. I’ve updated firmware for the the BLE Nano 2, but can’t get anything to work through mbed. Any idea what’s going on?
Specs say mbed is supported, but this doesn’t seem to be the case for V2.0


#5

Hi,

Please refer to this:
https://github.com/redbear/nRF5x/blob/master/docs/Mbed_IDE_User_Guide.md


#6

Thanks Cheong, this worked well.
I’m also going to try the V1 as I am planning on using with some fairly novice users.
Cheers


#7

I did the add to the platform but was unable to get blinky or hrm to work. I am on a linux system. I tried both saving to the daplink as well as drag and drop but no luck.

Thanks for any help!


#8

The link is out of date. Here’s the new link:

MBED IDE User Guide


#9

I should have looked earlier. Remapped LED1 to p11 and blinky works. On to bigger and better things.


#10

Any updates on this mbed support for nano v2?
Had used the simple control.hex for my stuff; but i would like to further shave off current by slowing down the advertising rate.
Any plans to make v2 like v1 in mbed at all?