Duo (cyan flashing ends with red flash)


#1

So I’ve been using my duos for weeks now,

I have quite a few and recently I’ve been faced with this problem,

The duo just flashes cyan then ends it with a red flash. no matter what I do, it cannot connect to the particle cloud and it is so sudden as the same duo has connected successfuly before

keep in mind i am using it with a particle power shield.

I tried the following:
downlaod and install dfu.util version 0.8
run the following commands:

sudo dfu-util -d 2b04:d058 -a 0 -s 0x8008000 -D fac-dct-r1.bin

sudo dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

press the reset button

I can go back into listening mode but it makes no difference, I am using screen on linux to connect the devices to my wifi network

sudo screen /dev/ttyACM0

type in

w

and follow the instruction to connect to wifi

I would appreciate the help as I need a solution urgently

regards,

B


#2

Blinking Cyan may indicates the need of a PUBLIC KEY RESET.
https://docs.particle.io/support/troubleshooting/common-issues/photon/#blinking-cyan

And you have tried but still not working.

We suggest

  1. Have you backed up your device private key? if not, you should do it first (hopefully not too late)
  2. Pease check that you have the latest firmware (v0.3.1 at this moment)
  3. Then try to provision your Duo to the Particle cloud again by using one of the methods mentioned on our Firmware Deployment Guide.
    https://github.com/redbear/Duo/blob/master/docs/firmware_deployment_guide.md

#3

I wonder if you need to use the Duo’s USB identifer “2b04:d058” for the second command. The “2b04:d006” identifier is from the Photon’s documentation.