Failing to download


#1

Hello:
My Duo is connected with ST-LINK v2, and I try to build and download WICED program but it’s failed.

Console:

17:51:04 **** Build of configuration Default for project 43xxx_Wi-Fi ****
“C:\WICED\WICED-Studio-4.0\43xxx_Wi-Fi\make.exe” redbear.blink-RB_DUO download JTAG=RBLINK
MAKEFILE MAKECMDGOALS=redbear.blink-RB_DUO download OTA2_SUPPORT is disabled
Building Bootloader
Finished Building Bootloader

redbear.blink-RB_DUO
----------------------------------|---------|---------|
| | Static |
Module | Flash | RAM |
----------------------------------±--------±--------|
crc | 1060 | 0 |
Host MCU-family library | 13088 | 2485 |
Interrupt Vectors | 388 | 0 |
libc | 23441 | 3064 |
Networking | 1001 | 8523 |
NetX-Duo - Interfaces & Stacks | 0 | 16 |
Other | 3911 | 92 |
Packet Buffers | 0 | 23086 |
platform | 1252 | 264 |
RAM Initialisation | 2340 | 0 |
resources | 16 | 0 |
Ring_Buffer | 116 | 0 |
Startup Stack & Link Script fill | 9 | 7 |
ThreadX | 7880 | 396 |
Wi-Fi Firmware | 382736 | 0 |
WICED | 2884 | 936 |
WWD | 12734 | 3059 |
----------------------------------±--------±--------|

TOTAL (bytes) 450516 41928

Merge all bin files into a single bin for MSD upload
Downloading Bootloader …
build\waf.bootloader-NoOS-RB_DUO\binary\waf.bootloader-NoOS-RB_DUO_PAD.bin
build\redbear.blink-RB_DUO\DCT.bin_PAD.bin
build\redbear.blink-RB_DUO\binary\redbear.blink-RB_DUO.bin
已复制 1 个文件。
Location: build/redbear.blink-RB_DUO/binary/redbear.blink-RB_DUO.bin_MSD.bin
“**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. "
Downloading DCT …
"
OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. "
Downloading Application …
"
OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****”
Build complete
Making .gdbinit

17:51:07 Build Finished (took 3s.132ms)

and openocd_log.txt:

Open On-Chip Debugger 0.10.0-dev-00224-g217aaab-dirty (2016-09-08-15:37)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Unlock
Info : auto-selecting first available session transport “hla_swd”. To override use 'transport select '.
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : Unable to match requested speed 1000 kHz, using 950 kHz
Info : Unable to match requested speed 1000 kHz, using 950 kHz
Info : clock speed 950 kHz
Error: open failed
in procedure ‘init’ called at file “./tools/OpenOCD/stm32f2x-flash-app.cfg”, line 10
in procedure ‘ocd_bouncer’


#2

Hello,

I got the same behaviour, @guohui told me to check whether I was using the blue led. I don’t know the main reason but it somehow meddles with the jtag programming.

Please try to program another program that doesn’t touch the blue led.

rifo


#3

Hello @riforifo

Thanks for your help.
It’s should be press reset button when download begin.
And I have erase ROM begin download. so I don’t think this problem is about blue led.

Jerry