Flash Nano 2 without DAPLink?


#1

Looking for some guidance here… I recently purchased the Nano v2 BLE board from the Particle store because it looks perfect for my project. The internet tells me that the DAPLink debugger is the proper device used to flash firmware onto the Nano (https://github.com/redbear/nRF5x/tree/master/USB-IF). However, after hours of searching, I can’t find one for sale anywhere. Particle’s website makes no mention of the DAPLink and instead references their Particle Debugger (https://store.particle.io/products/particle-debugger), but its not available until November…

Is there another way to flash the Nano 2 without the DAPLink? Can I use a different, more generic USB to serial cable or JTAG/SWD debugger (https://www.adafruit.com/product/3571)?

Any help would be most appreciated!


#2

Take look at https://github.com/sandeepmistry/arduino-nRF5
If you order a blackMagic board https://www.adafruit.com/product/3839
you need to also order a cable adaptor https://www.adafruit.com/product/2743 (or similar)
l have not tried programming yet, still waiting for the adaptor.


#3

I think you can use any SWD debugger. But there are several other functions that DAPLink provides, like the drag and drop programming of the flash memory or the integrated serial port. I haven’t tested any other solution than the DAPLink, so I’m not sure if any other debugger really works, but in theory it should be possible.


#4

Not sure how much you want one or if they can ship overseas but there are some on Amazon Japan’s site. Search https://www.amazon.co.jp/ for “RedBearLab BLE Nanoキット V2” . They have 9 left and the cost is around US$35. These are sold by Switch Science https://www.switch-science.com/catalog/3444/

Its the same as this one: https://www.sparkfun.com/products/retired/14154

This is a set with the programmer and a Nano 2. From my experience it will be good to have a backup device. Be careful when you plug it in as it can fit both directions and one way will cause it to fry. Works well otherwise.


#5

I flashed it once with a Segger J-Link in SWD mode, and it was no problem. It was even necessary because I accidentally corrupted some registers which caused an error where DAPLink could not Flash any longer.

The J-Link was able to reset/repair and DAPLink worked again. I also don’t recommend the DAPLinks drag-drop flash feature because on every drag drop the complete program memory is reset which deletes the softdevice. On this way you always need to merge the softdevice & application binaries and flash together in one file. Therefore the reprogramming process is longer every time.