"Getting Started with Blend Micro" does not work


#1

Hello,
I carefully followed the “Getting started with Arduino IDE” (IDE version is 1.8.1.), but it didn’t work.
The Blend boards do not appears in the board menu…
And If i choose the “Boards Manager” menu item I got a long series of error messages:
“Invalid library found in C:\Users\massi\Documents\Arduino\libraries\hardware: C:\Users\massi\Documents\Arduino\libraries\hardware”
I can’t work with the board.
Any help?

p.s. I also tried to copy the blend folder into Arduino / hardware /arduino installation folder. In this case, when I launche the IDE it crashes and exit.

I tried also with CodeBender, as you recommend.
Are you joking?
It’s closing down!!!:
https://codebender.cc/next-chapter

Anyway, I found a solution digging in the net:

Go the Arduino preferences and add the line
https://redbearlab.github.io/arduino/package_redbearlab_index.json
To the additional;boards manager URL.
Then go to Boards Manager and add
RedBear AVR Boards and nrf 512822.

These are the info you should put in the Getting started.


#2

Hi @magrini, Sorry for bringing you troubles at getting started. Please follow the guide on GitHub: https://github.com/RedBearLab/Blend

The guides on RedBearLab website are deprecated.

Regards,
guohui


#3

I tried using the github link and pasted it into the preferences but there was an error in installation. Is there another link I should be using? Also, I am using a mac and I think that is the issue. Is there another link for mac users? Please help!

Thank you


#4

Hi @vprema, Install a board package via the Arduino Boards Manager is the best way you should believe. I think it is nothing to do with the Mac. What’s the error it prompted? Make sure the link you pasted is correct and the network is stable.