Discussion Forums

IoT_pHAT_pHAT-with-dt.eep compilation fails

#1

I am using the IoT_pHAT with a new Pi Zero and NOOBS v1.9.2
Downloaded IoT_pHAT_pHAT-with-dt.eep and eepflash.sh to my Downloads directory with no problems
Using: sudo ./eepflash.sh -f=IoT_pHAT-with-dt.eep -t=24c32 -w
results in:

./eepflash.sh: 116: ./eepflash.sh: Cannot create /sys/class/i2c-adapter/i2c/i2c-0/new_device: Directory non-existent
writing…
dd: failed to open ‘/sys/class/i2c-adapter/i2c-0/0-0050/eeprom’: No such file of directory
Error doing I/O operation

What should I do?
Note: Error is copied by hand. Any errors are my fault! :slight_smile:

#2

you might need to add “dtparam=i2c_vc=on” in /boot/config.txt leave off quote marks.

#3

I have the same problem with the same message. I added the line in config.txt as suggested but the result stays the same. In the 12c-adapter directory there are no subdirectories…
What can I do?

#4

Had already done that.

#5

I followed the instructions from another topic. Removed the HAT en disabled the camera.
Then power up without the HAT and then connect the HAT to the RPi.
Now I could burn the eeprom. When I check with $ cat /proc/device-tree/hat/product
I get the right reply. “IoT pHAT w/eep_v0.3”
But still no Wlan0. When i check $ ls /proc/device-tree/soc/ i do not see a subdirectory iothat.
40 pins soldered correctly but i do not know what you mean with check the I2C ID EEPROM pins (see the pinout diagram for details).