New Duo - continually cycles from cyan to red


#1

Hi all, I have a new Redbear Duo but seem to have gone awry somewhere as it won’t stay connected to the cloud.

It came with v0.2.3. Another person played with for a few days, I couldn’t be sure if they had fully provisioned it with a private key or not.

First I dumped the existing firmware:

dfu-util -d 2b04:d058 -a 0 -s 0x8004000 -U dct_backup.bin // for a pre 0.2.4 version
dfu-util -d 2b04:d058 -a 1 -s 2082 -U server_public_key.der
dfu-util -d 2b04:d058 -a 1 -s 34 -U device_private_key_backup.der

Then I upgraded to v0.3.1:
dfu-util -d 2b04:d058 -a 0 -s 0x8008000 -D fac-dct-r1.bin // for a post-0.2.4 version
dfu-util -d 2b04:d058 -a 0 -s 0x8020000 -D duo-system-part1-v0.3.1.bin
dfu-util -d 2b04:d058 -a 0 -s 0x8040000 -D duo-system-part2-v0.3.1.bin
dfu-util -d 2b04:d058 -a 2 -s 0x140000 -D duo-fac-web-server-v0.3.1.bin
dfu-util -d 2b04:d058 -a 2 -s 0x180000 -D duo-wifi-r1.bin

And replaced the keys previously dumped:
dfu-util -d 2b04:d058 -a 1 -s 2082 -D server_public_key.der
dfu-util -d 2b04:d058 -a 1 -s 34 -D device_private_key_backup.der

Used putty ‘w’ to register my AP. It did seem to be successful, it pulsed cyan for a while, and reported a webserver IP address and the message “Make sure your smart device acting as web client is connecting” (it cut out here and the putty session terminated)

But now it appears to be continually reconnecting to the cloud - the LED cycles as follows:

  • cyan (1 sec)
  • green fast flash (2 sec)
  • cyan fast flash (2 sec)
  • cyan slow pulse (5 sec)
  • red irregular flashes (10 sec)
  • … and around again.

Other observations:

  • I can see the COM port in Arduino IDE v1.8.5, but “Get Board Info” returns “BN: Unknown board, VID: 2B04, PID: C058, SN: Upload any sketch to obtain it.” There is no “Redbear Duo” board option as suggested in the tutorials.
  • I registered the device key in Particle.IO and it does show up with a cyan icon, but because of the continual reconnecting I can’t do much else.
  • The Redbear Duo Android 0.2 apk has never worked, with either 0.2.3 or 0.3.1 firmwares. With the Duo in listening mode it shows the device with an expected name “Duo-6xxx” and a mac of “FF:FF:FF:FF:FF:FF” but any attempt to connect always times out. Hence why I’ve used the serial method for all of the above.

Can anyone suggest any tips? Thanks!


#2

Problem solved. I was using a wireless AP connected to an enterprise network. When I changed to a different AP with direct internet access it worked.


#3

I am glad to hear that, cheers!


#4

I’m lost… I have similar problem like this. Tutorial how to fix it?


#5

@opensource,

Did you get it working before?


#6

Try putting back the public key to the Duo with this guide: