No wlan0 with fresh install of jessie lite on raspberry pi zero w/raspiCam


#1

just set up a new raspberry pi zero v1.3 with camera interface. fresh new Jessie image release 8.0. IOT Phat works on older raspberry pi zero. on the nww setup i get No Wireless interfaces found.
I was able to read the firmware which was v.3 I was able to load the current .4 version firmware and verify that it installed after reboot. bluetooth is working fine and I am using wireless mouse and keyboard with no Problems. iothat is found under “ls /proc/device-tree/soc/”. I tried plugging in a usb wifi adapter and that also isnt recognized but shows up with lsusb. tried to force wlan0 with ifup to no avail. I have done numerous searches and tried alot of different procedures. if anyone can point me in the right direction I would appreciate it. I am almost 100% sure it is not hardware related but probably related to raspberry Jessie…


#2

I did get it working by transferring the IOT Phat to my older Pi zero along with the SD card from the new unit did all of the apt-get updates and rpi-updates and swapped it all back it is now working as expected! YAY!