No wlan0 with fresh install of Jessie Lite on Raspberry Pi Zero


#1

I’ve double- and triple-checked my soldering with a continuity tester, tried re-flashing the EEPROM with the latest from github, and everything else I could find to try.

Just to answer a few questions before they’re asked:

It does seem to be reading the EEPROM correctly:

[email protected]:~ $ ls -al /proc/device-tree/soc/iothat/
total 0
drwxr-xr-x 2 root root 0 Sep 25 16:10 .
drwxr-xr-x 44 root root 0 Sep 25 16:10 …
-r–r--r-- 1 root root 7 Sep 25 16:10 name
-r–r--r-- 1 root root 4 Sep 25 16:10 pinctrl-0
-r–r--r-- 1 root root 8 Sep 25 16:10 pinctrl-names
-r–r--r-- 1 root root 5 Sep 25 16:10 status

The only lines I’ve added to /boot/config.txt are:

# Enabling USB OTG
dtoverlay=dwc2

# Enabling I2C for IoT PHAT and changing the UART Clock
dtparam=i2c_vc=on
init_uart_clock=48000000

And finally, here’s the full output of an ifconfig -a

[email protected]:~ $ ifconfig -a
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:324 errors:0 dropped:0 overruns:0 frame:0
TX packets:324 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:26448 (25.8 KiB) TX bytes:26448 (25.8 KiB)

usb0 Link encap:Ethernet HWaddr 96:e0:8e:fb:67:eb
inet addr:169.254.179.223 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::2cbc:c59e:d5b1:6e8e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:719 errors:0 dropped:9 overruns:0 frame:0
TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:98635 (96.3 KiB) TX bytes:33042 (32.2 KiB)


#2

although the answer is probably yes, i wondered if you have done,
sudo rpi-update ?


#3

Yep. It should be fully up-to-date with all the latest packages as of… Saturday, I think.


#4

A fresh install is known to cause wlan problems on raspberry pi. I re-installed Jessie on an raspberry pi 3b and the wlan was down for no reason.
On their forum a cheap router was suggested to be the cause of issue is.
Which could be the case by me :slight_smile:


#5

I’m having a problem on pi-zero v1.3. Is the Redbear compatible with this release?
Symptoms: pi-zero doesn’t boot, no blinkies … dead. Remove the HAT and it boots fine.
Tried the HAT on another pi (model B v1.1) and, while not configured, got blinkies on the HAT, and, the pi booted.

I’m suspicious of the pi-zero header (I didn’t solder it, it came with it from vendor). If you need more info, I’d be glad to add what I can. For now, working around the problem with a CanaKit.


#6

Whoops, nevermind. It turns out that a technician had soldered a header onto the pi-zero and there was a short.