pHAT v1.0 cannot be recognised by Pi Zero v1.3


#1

Bought 5 pcs of pHAT v1.0 back in Sep 16 but had to wait for Pi Zero to be available until now. This pHAT firmware version is recognised on my Pi 3 but not so on my newly bought Pi zero v1.3. I tried all the possible remedies recommended in this forum but all failed. When mounted on the Pi Zero, it shows connection via green LED light but the latest Raspbian 2.1.0 don’t seem to recognise the firmware. When I tried to flash firmware 1.4, it failed to flash indicated that the pHAT is not present. Tried all five of them but the same disappointed results. Btw - I did not hard solder the pHAT to the pi Zero. Instead it showed connection (green LED on the pHAT) by using the Male-Female Solderless Pin Header Connector bought from eBay …

For your advice please.


#2

I have the same issue and I’ve done all that I have found. My is also recognized my my pi3 but not a zero.


#3

Use Pi Zero input: cat /proc/device-tree/hat/product
Is there a printed message on the terminal?


#4

Shun-gan… thanks for your suggestion but no luck. I managed to reflash pHAT to v0.4 using my Pi 3. However, the newly flashed pHAT still cannot be detected by my pi Zero v1.3 altho the pHAT green led is ‘on’.