REDBEAR DUO DFU-UTIL problem


#1

Hi

I have just bought REDBEAR DUO, and I am new to REDBEAR DUO.
I would like to use WICED on Linux with Redbear Duo patch for development.

There are some problems that I could not understand.
I have tested with Ubuntu 16.04 and Ubuntu 17.10, all have errors:

  1. DeviceID: VendorID:
    According to FW compilation guideline on Linux,
    https://github.com/redbear/WICED-SDK/blob/master/docs/FW_Make.md

The device ID and vendor should be 2b04:d058
But when I checked with lsusb:
2b04:c058

Thus I do not know why device IDs are different.

  1. DFU-UTIL:
    After installing dfu-util, I could not see redbear duo:

$ dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.

  1. Compilation and uploading in DFU mode:
    Following guideline on FW compilation on Linux, I installed WICED SDK 5.01, add RedBear DUO WICED patches, compile for RGB example. It compiles without any error.
    ./make redbear.rgb-RB_DUO

I tried to load firmware:
dfu-util -d 2b04:d058 -a 0 -s 0x08010000 -D redbear.rgb-RB_DUO.bin

It said error (suffix error)

Thus I wonder if someone could tell me :

  • Why Device ID and Vendor ID are different according to guideline ?
  • Why the dfu-util could not list the Redbear device (dfu-util -l) ?
  • Why I could not download firmware in DFU mode?

Thanks a lot in advance

LTSON36


#2

Hi

I have tried again on Windows 10, it works fine, exactly as guidelines.
dfu-util -l shows device ID and vendor 2b04:d058.

uploading firmware by dfu-util works fine.