Redbear nano v2 arduino unable to upload


#1

Background info:
Product being used, Redbear nano v2 with dap link v1.5
Product used successfully, Redbear nrf51 board

Application for the redbear: to scan all bluetooth device, and print out relevant rssi for my external ibeacon
I do not need help with the codes, i just need help with why the heck the nano v2 is not working after i have tried everything.

Arduino version used and tried, 1.8.6 , 1.8.5, 1.8.0,
Code uploaded, BLE scan report,

Tried almost everything, and red thru all the arduino and nano v2 related threads to find the answer, but to no avail.

The only thing i am able to do is to upload through drag and drop, and i really need to use arduino for my application thou!!! So someone save me, or just give me a confirmation that there is currently an error that is why it is not working.

Any administrator pls give me a confirmation, or some help, most sincere and warmest thank yous.

Thanks in advance,
Jeslyn
[email protected]

Upload message

Sketch uses 55660 bytes (10%) of program storage space. Maximum is 524288 bytes.
Open On-Chip Debugger 0.10.0-dev-00254-g696fc0a (2016-04-10-10:13)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 1
adapter speed: 10000 kHz
cortex_m reset_config sysresetreq
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000008e4 msp: 0x20000400
erased address 0x0007f000 (length 4096) in 0.015006s (266.560 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f000 in 0.639972s (0.006 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f008 in 0.660939s (0.006 KiB/s)
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000008e4 msp: 0x20000400
** Programming Started **
auto erase enabled
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 61440 bytes from file C:\Users****\arduino_build_587307/BLE_ScanReport.ino.bin in 3.169948s (18.928 KiB/s)
** Programming Finished **
** Verify Started **
verified 58280 bytes in 0.340986s (166.910 KiB/s)
** Verified OK **
** Resetting Target **
shutdown command invoked


BLE Nano Kit v2 Issues (MB-N2)
#2

My Nano V2 is also unable to upload even a simple Blink.ino sketch from Arduino IDE 1.8.5 (Windows 10 64-bit, Board=BLE_Nano2, Programmer = RBL_DAPLink). All pre-compiled examples that I drag and drop from https://github.com/redbear/nRF5x/tree/develop/nRF52832/test, however, work perfectly.

My output from an unsuccessful upload is below. Please suggest a solution promptly as this relates to basic, advertised functionality.

Thanks!

Sketch uses 17120 bytes (3%) of program storage space. Maximum is 524288 bytes.
Open On-Chip Debugger 0.10.0-dev-00254-g696fc0a (2016-04-10-10:13)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 1
adapter speed: 10000 kHz
cortex_m reset_config sysresetreq
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000007dc msp: 0x000008c0
erased address 0x0007f000 (length 4096) in 0.028962s (138.112 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f000 in 0.640091s (0.006 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f008 in 0.662999s (0.006 KiB/s)
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000007dc msp: 0x000008c0
** Programming Started **
auto erase enabled
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 20480 bytes from file C:\Users\digit\AppData\Local\Temp\arduino_build_755389/Blink.ino.bin in 1.267087s (15.784 KiB/s)
** Programming Finished **
** Verify Started **
verified 17988 bytes in 0.256174s (68.572 KiB/s)
** Verified OK **
** Resetting Target **
shutdown command invoked


#3

The log looks good, did you try a simple blinky sketch to test first?
Or, try to export the hex from the Arduino IDE and using drag and drop method to test your sketch first.
Let me know the result.


#4
  1. Drag and drop of https://github.com/redbear/nRF5x/blob/master/nRF52832/test/nRF52_Blink.hex WORKS.

  2. Uploading the following sketch via Arduino IDE 1.8.5 DOESN’T WORK with log messages in digsub post above.

void setup() {
// initialize digital pin LED_BUILTIN as an output.
pinMode(13, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
digitalWrite(13, HIGH); // turn the LED on (HIGH is the voltage level)
delay(1000); // wait for a second
digitalWrite(13, LOW); // turn the LED off by making the voltage LOW
delay(1000); // wait for a second
}


#5

Hi,

Please try to select tools -> programmer -> RBL_DAPLink and then tools -> burn bootloader.
After that, try your blinky and BLE HRM.


#6

Burning the bootloader did the trick. Thanks!


#7

Hello cheong, thank you for replying!!

regarding your solution,

for my serial monitor screen, "Start… " appears, but nothing else appeaars.

this is my output

Sketch uses 55660 bytes (10%) of program storage space. Maximum is 524288 bytes.
Open On-Chip Debugger 0.10.0-dev-00254-g696fc0a (2016-04-10-10:13)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 1
adapter speed: 10000 kHz
cortex_m reset_config sysresetreq
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000008e4 msp: 0x20000400
erased address 0x0007f000 (length 4096) in 0.014006s (285.592 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f000 in 0.639975s (0.006 KiB/s)
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 4 bytes to 0x0007f008 in 0.660919s (0.006 KiB/s)
nrf52.cpu: target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x000008e4 msp: 0x20000400
** Programming Started **
auto erase enabled
Warn : using fast async flash loader. This is currently supported
Warn : only with ST-Link and CMSIS-DAP. If you have issues, add
Warn : “set WORKAREASIZE 0” before sourcing nrf51.cfg to disable it
wrote 61440 bytes from file C:\Users\Jesly\AppData\Local\Temp\arduino_build_584391/BLE_ScanReport.ino.bin in 3.155960s (19.012 KiB/s)
** Programming Finished **
** Verify Started **
verified 58280 bytes in 0.340987s (166.910 KiB/s)
** Verified OK **
** Resetting Target **
shutdown command invoked


#8

oh so sorry, the code i have uploaded is the example ble scan report!


#9

Thank you for pointing out this, too. Actually it should not need to do this step, we will look into this. :+1:


#10

So, does it work for you now?


#11

No it does not work. Only " start " appears.


#12

I just tested but it works just fine. Could you send your hex file to me to try?
It should be in this folder or you:
C:\Users\Jesly\AppData\Local\Temp\arduino_build_XXXXXX


#13

Hi Cheong,

I had exactly the same issue of digsub user.

I burned the bootloader and tried again to upload my skatch (the same of digsub), but no success.

Can you help me please?


#14

how do i send you that !!


#15

its still not working for me


#16

Hi all,

I resolved this way. I followed the instaructions here:

In my case, I had to select the DAPLink_V1.0_Interface_nRF52.bin according to the version of my DAPLink board.

Then, in Arduino IDE, I selected:

Programmer:RBL_DAPLink

Board:BLE_Nano2

Then: burn bootloader

After, reconnect the board to the pc.

After compiled a sketch and uploaded and everything was fine.

Hope this could resolve your problems