Serial.println() doesn't work with Serial Monitor


#1

Ran a few example projects with the Serial.println(“xxxxxxxx”). Opening the Serial Monitor from the Arduino IDE doesn’t really display the data at all. However, the Serial.write() seems to work fine.
Termite serial console doesn’t work as well.


Serial Monitor not working with BLE Nano 2
#2

How about Serial.println(F("xxxxxx"))?


#3

I tried it doesn’t work.


#4

Have you updated the board package and nRF8001 library (See the software checklist)?

BTW, What Arduino version are you using?


#5

Hi Guohui,
I have the library in the checklist. I am using IDE 1.6.8. I gave up on this board now to focus on BLE Nano.


#6

Before giving up I think you should have a try: Serial.println(xxxx, HEX) or Serial.println(xxxx, DEC).


#7

Hi, I tried this, too. It’s not working for me either. No serial output with BLE Nano Kit v2 and Arduino (1.8.6.0). So, it seems this issue is not limited to the Blend Micro. Do you have any other tip?

#include <nRF5x_BLE_API.h>

void setup() {
  Serial.begin(9600);
}

void loop() {
  Serial.println("blub!");
  Serial.println(42, HEX);
  Serial.println(42, DEC);
  Serial.print(F("Hello World"));
}

#8

I solved my issue by updating the DAPLink FW via https://github.com/redbear/nRF5x/tree/develop/USB-IF and verified that my Arduino IDE board settings are “BLE_Nano_2” :slight_smile:.