Discussion Forums

Services.h and not being able to find the BLE Shield

#1

Hi,

We recently purchased the BLE Shield v2.1 we tried setting it up on a uno via here:
http://redbearlab.com/getting-started-bleshield

and after installing and loading the BLEControllerSketch example, the compile dies on:

` #include <services.h>

                  ^

compilation terminated.`

We tried following the instructions by installing libraries directly inside Arduino as described here:

as well as directly getting it from github:


In all scenarios, services.h could not be found.

We did manage to notice a few things:

  1. Commenting out services.h allows for the sketch to compile and upload
  2. Copying out services.h from other example sketch folders and putting it in the root folder of the BLE library allowed for the error to go away.

However with either of the top 3 libraries and resolving the services.h problem, none of my devices can find the BLE shield.

Currently running:

  • Windows 10

Tested via:

  • Samsung Galaxy S7 Edge
  • Windows PC with bluetooth 4.0 dongle

Thanks for any information you can provide.

#2

Hmmm putting back the jumpers made it work again. For now…

#3

Regarding the compilation problem,

  1. Make sure you’ve removed the old nRF8001 relative libraries
  2. Copy the downloaded libraries, which from github as the same link as you post, to the Arduino library folder.
  3. Then install the RedBear AVR Boards package via Arduino Boards Manager.

After all of that, everything should be fine.