SOLVED - Arduino IDE compilation error "...core\core.a'; reason: File exists"


#1

My settings: Arduino 1.88, Nano2, Windows10, HP Specter

Error message:

C:\Users\XXX\AppData\Local\Arduino15\packages\RedBear\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-ar: unable to rename 'C:\Users\XXX\AppData\Local\Temp\arduino_build_246990\core\core.a'; reason: File exists

exit status 1
Error compiling for board BLE_Nano2.
  • Note that, I am able to verify and upload compiled code successfully with the default Arduino Genuino Uno board and other non-RedBear boards in the Arduino IDE, but not the BLE_Nano2 board, it doesn’t go as far as upload; hence this issue is at the compilation level and with RedBear boards (and based on the internet possibly others too).

  • I noticed others struggled with this issue, I tried all the following without much luck:
    – Turned off antivirus and firewall >> doesn’t work
    – Uninstalled Arduino IDE >> doesn’t work
    – Deleted temp files >> doesn’t work
    – Tried version Arduino 1.0, 1.6, beta >> doesn’t work
    – Moving main folder from C://program/arduino file to C://arduino >> doesn’t work
    – Gave administrative permission >> doesn’t work
    – Running it as Windows XP SP3 >> doesn’t work

SOLVED:

  • Don’t just turn off the firewall, go ahead and completely uninstall it, in my case that was ZoneAlarm.

Hopefully this will help people out there!