[SOLVED] Blend Micro - cannot compile with arudino IDE


#1

Hi everyone,

my problem is the following: I have bought a Blend Micro and followed all the initial steps as suggested in the “Getting started guide” (http://redbearlab.com/getting-started-blendmicro), by adding the folder “hardware” in the Document/Arduino folder. I could not see any Blend in the Board Managers.

As soon as I tried to compile an empty script I receive the error that the file “boards.txt” is not found in the folder \Documents\Arduino\hardware\blend\bootloaders… but actually this file exists in the upper folder (blend), so I have simply placed the file in the “bootloaders” folder. So, I could see in the Arduino Board Managers I can see 3 voices: Blend, Blend Micro 8MHz & 16Mhz.

So, then I tried to compile again an empty script and what I got is an erro saying that “The selected board require ‘arduino:arduino’ core which is not installed.” I tried to update all the libraries and boards, but nothing (I have the last version Arduino 1.8.1 on Windows 10).

I don’t know what to do, please help me :frowning:
Thank you very much!


#2

Hello,

I saw a new post for the nrf51822 and I followed it (“Getting GCC compiler error while using redbear nrf51822 with Arduino package”), because I thought it could be a similar issue.

I added “https://redbearlab.github.io/arduino/package_redbearlab_index.json” to my “Additional Boards Manager URLs” and installed the boards… Now it seems I can compile and also upload the sketch! but I am still getting the following error:

Warning: platform.txt from core ‘RedBearLab AVR Boards’ contains deprecated recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} “{source_file}”, automatically converted to recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} “{source_file}” -o “{preprocessed_file_path}”. Consider upgrading this core.

Sketch uses 4574 bytes (15%) of program storage space. Maximum is 28672 bytes.
Global variables use 149 bytes (5%) of dynamic memory, leaving 2411 bytes for local variables. Maximum is 2560 bytes.

Do I have to worry? What’s worng?
Thank you


#3

This is a warning to us only, nothing to do with you. The sketch is compiled successfully. Just go ahead!

Kind regards,
guohui


#4

Nice to hear that!
Thank you very much!