[Solved] New Redbear Duo does not work the SimpleChat Demo


#1

The new Redbear Duo does not work the SimpleChat Demo. When I send messages from computer to iPhone, there is no reply on the iPhone. My old Redbear Duo works well on this demo.


[Solved] BLEController Sketch Not Working with BLEController App using duo
#2

I started with a new one running at v0.3.0 and it didn’t work. Updated to 0.3.1 using the 0.3.2 board software in arduino but same deal. Reading the docs, it’s a bad idea to roll back to 0.2.x as they use a different memory space map. I’ve emailed RedBear with no response and left forum messages on particle. Going to try emailing particle next week for a response.


#3

According to your suggestion, I changed all sendNotify to sendIndicate and my old project works well now. Thank you very much. I think it is not a good idea to change the interface function name when updating the firmware. I set up firmware 0.3.0; 0.3.1; 0.3.2 a lot of times. And I even set up firmware 0.2.x. Maybe we have lost Redbear team support. I have not the ability to decode the library as you can. Whatever, at least my project works.


#4

sendIndicate works but it’s not good for sending large amounts of data since it requires an ACK before it can send the next message. I’ve experienced this on my side when I try to send data at a fast rate, there is a fixed latency that occurs as opposed to other RedBear examples. If you’re just sending small single commands via sendIndicate that’s totally fine. They still need to fix sendNotify for full functionality on this board.


#5

I just send small amounts of data several seconds. sendIndicate is OK for my project. When Duo sends message to my iPhone, there is a little hesitation. But it is not a problem. Thank you for your explanation. By the way, the BLEController program is not perfect in iPhone.


#6

@ding-lin, did it appear the same result after you downgrading the system firmware to 0.3.1 or even older: https://github.com/redbear/firmware/releases? Or did it appear on your old Duo running the 0.3.2?


#7

#8

When I set up the firmware 0.3.1, the program could compile and upload to the board. But the program could not run on the board. The Duo board ran the original program. The problem appears on my old Duo after upgraded to firmware 0.3.2. When downgraded to firmware 0.3.1, my old Duo also met the same situation as the new one.


#9

#10

Flashed to 0.3.3 and sendNotify is working again. Thanks for the fix!