Trouble uploading Arduino Sketch


#1

I was able to successfully upload the Blink Sketch and run it on my Nano Kit but only once. I then wanted to upload a more complex sketch and it reported errors with OCD (debugger?).

Now, I get the same error even trying to upload the Blink Sketch. Could I have “bricked” the bootloader? I haven’t tried reburning it.

Sketch uses 31724 bytes (12%) of program storage space. Maximum is 262144 bytes.
C:\Users\Bob_M\AppData\Local\Arduino15\packages\RedBear\tools\openocd\0.10.0-dev-nrf5/bin/openocd.exe -d2 -s C:\Users\Bob_M\AppData\Local\Arduino15\packages\RedBear\tools\openocd\0.10.0-dev-nrf5/scripts/ -f C:\Users\Bob_M\AppData\Local\Arduino15\packages\RedBear\tools\openocd\0.10.0-dev-nrf5/scripts/interface/cmsis-dap.cfg -f C:\Users\Bob_M\AppData\Local\Arduino15\packages\RedBear\tools\openocd\0.10.0-dev-nrf5/scripts/target/nrf51.cfg -c init;reset halt;flash erase_address 0x3FC00 0x400;flash fillw 0x3FC00 0x00000001 1;flash fillw 0x3FC04 0x000000FF 1;flash fillw 0x3FC08 0x00000000 1;program {{V:\ArduProject/BLE_beacon.ino.bin}} verify reset exit 0x1C000
Open On-Chip Debugger 0.10.0-dev-00254-g696fc0a (2016-04-10-10:13)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 2
Info : only one transport option; autoselect ‘swd’
cortex_m reset_config sysresetreq
adapter speed: 1000 kHz
Info : CMSIS-DAP: SWD Supported
Info : CMSIS-DAP: Interface Initialised (SWD)
Info : CMSIS-DAP: FW Version = 1.0
Info : SWCLK/TCK = 0 SWDIO/TMS = 1 TDI = 0 TDO = 0 nTRST = 0 nRESET = 1
Info : CMSIS-DAP: Interface ready
Info : clock speed 1000 kHz
in procedure ‘init’
in procedure ‘ocd_bouncer’

An error occurred while uploading the sketch


#2

This log looks as expected, did you try using drag & drop method to see if the kit is still working?


#3

Thank you, for now it seems I am able to upload sketches. Though I have the COM port set at COM23, Serial.Print produces no output on the monitor. Can you point me to an Arduino Example that uses Serial.Print?

Thanks.
Bob M.