Turning off DFU during start up


#1

Hi all,

I am using Arduino IDE and BLE Nano to write a fairly simple beacon program for the BLE Nano. I am running a Linux computer to receive the beacon info from the Nano. My problem is that when I power up the Nano while the computer is on the LED on the Nano flashed fast for 5 seconds and goes into DFU mode. This messes up the Linux code and the computer has to be restarted to start working again.

Is there any way to make the Nano not go into the DFU mode for 5 seconds on startup?

Your assistance is much appreciated!


#2

Hi mebarrington,
Use this https://github.com/RedBearLab/nRF51822-Arduino/tree/S130/bootloader
SoftdeviceS130-1.0-Bootloader-20160824.hex:

Use MSD to update this bootloader, then use Arduino IDE to compile and upload.


#3

Good day!

I am currently working with the BLE Nano V1.5 to do some prototyping. Now, i have a problem which i hope you can help me with. When the nRF51822 starts up, the bootloader stays in DFU mode for 5 seconds for OTA. I would like to remove this 5 seconds start-up delay (and the OTA functionality). Is this possible and how can i do this?


#4

Hi jelleif,

Have you tried downloading the new bootloader from the previous post?

I had great success loading the new bootloader to the BLE Nano. All you do it drag and drop this file “SoftdeviceS130-1.0-Bootloader-20160824.hex” from the folder to the mbed MSD. It disables the DFU mode.

How are you loading firmware onto the BLE Nano? Arduino IDE, MBed?

If you are using the Arduino IDE you will need to select the alternative BLE Nano (v1.5, 32k) in the board list. It was located at the bottom of the list of Boards in my case.

All the best.


#5

Wauw thank you very much for the fast and adequate response! I am using Arduino IDE and i indeed have the same BLE Nano (v1.5, 32k) board located at the bottom of the list. There is an other problem for me, when i try to drop and drag the bootloader to the nano i get this message: ‘The file ‘SoftdeviceS130_1.0_Bootloader_20160824.hex’ is too large for the desstination file system.’

p.s. i am uploading via the MK20 USB board.


#6

We are doing very similar things. I have seen that message before. I just restarted my PC and it worked. It takes some playing around to get familiar with.

All the best.


#7

The SoftdeviceS130_1.0_Bootloader_20160824.hex is an OTA bootloader which turn on the DFU instead of turning it off, right?


#8

Hi danlsk,
Refer to this docshttps://github.com/RedBearLab/nRF51822-Arduino/blob/S130/docs/DFU_User_Guider.md


#9

Hi Jixing,
The OTA doesn’t seem to time out when I used the BLEPeripheral.h library. See my other post question. The programmed device name was wiped off and never return.


#10

Disabling OTA / DFU on the BLE Nano seems to work fine, if you use the SoftdeviceS130_1.0_Bootloader_20160824.hex version in https://github.com/RedBearLab/nRF51822-Arduino/tree/S130/bootloader and rename it to bootloader.hex before uploading with the mbed method (drag file to MBED drive).


#11

Hi,

is there anywhere the source code for the boot-loader and some instructions how to compile it ?
I need to modify it a bit.
specifically change the advertising name from DFU_xxx to some more meaningful name, that will correlate with the mac address of the device.

Thanks,
Danny