Unknown component RB_Duo


#1

I’m trying to compile a BTStack example with WICED SDK 3.3.1.

I followed these resources:
RedBear WICED: https://github.com/redbear/WICED-SDK
BTStack: https://github.com/bluekitchen/btstack/tree/ble-api-cleanup/port/wiced

These are the steps I did:

  • Downloaded WICED SDK 3.3.1 from Broadcom.
  • Cloned RedBear WICED SDK and copied all files over those of the original WICED SDK.
  • Cloned BTStack into WICED-SDK-3.1.1/libraries folder
  • Change branch to ‘ble-api-cleanup’
  • executed /port/wiced/create_examples.py
  • Now running ‘./make btstack.spp_and_le_counter-RB_Duo’ cause this exception:

Making config file for first time
./tools/makefiles/wiced_config.mk:193: *** Unknown component: RB_Duo. Stop.
make: *** No rule to make target build/btstack_spp_and_le_counter-RB_Duo/config.mk', needed bymain_app’. Stop.

Any idea how to fix this?
What did I do wrong?


#2

Hi @jdboer,

Try running ‘./make btstack.spp_and_le_counter-RB_DUO’ , since the platform name is RB_DUO or RB_DUO_ext. You can probably find the folders that under ./WICED-SDK-3.3.1/platforms. For the make command line parameter format you can look into the Makefile under WICED-SDK-3.3.1.

Cheers!


#3

Hi @jdboer

I’m not sure what’s the correct platform name is. In my installation, which is older, it was RB_Duo, but it might as well have been changed in-between, so @guohui advice may help.

However, the WICED BTstack port didn’t compile until a few minutes ago. The examples compile for me now, but I’ll also will try over the weekend to test the examples on the new Duos.


#4

Hi @mringwal, just keep update with this add-on package for RedBear Duo using WICED SDK.

Cheers!


#5

Hi @guohui

I did update the add-on package. now, it’s RB_DUO. I’ve fixed the BTstack readme, too.

While it compiles now, the BTstack examples doesn’t properly start up. I’ll need to investigate/fix this before it can be use - it worked in the past, not sure which change caused an issue.

best
matthias


#6

@mringwal, Thank you very much for your enthusiastic support! I just want to give you a big hug :slight_smile:


#7

Hi @jdboer

I’ve enabled the logging and set it to use the default baudrate of 115200 in the BTstack repo. It’s working again.

That’s not great - I still have to get it to work 100% - but it should get you started.

Cheers,
Matthias