Unlocking RB link


#1

Hello,

On the github webpage it says that we need to unlock the rblink with RBDuo_Unlock.bin but I can’t find this binary. Can you please tell me where it is?

I can drag and drop …bin_MSD.bin programs to RBLink folder and program the duo

But when I try to program redbear via WICED IDE, I can only program it ONCE (right after using drag and drop programming) if I don’t use drag & drop programming then I get below error

OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****" Downloading Application …

I can see RBlink fine under device manager and use putty to receive debug messages, so I think my driver works fine.

can you please tell me what can be the reason for this?
thank you
rifo


#2

Hi @riforifo,

On the Duo, if it has run Particle firmware before, several sectors of internal flash are write protected. The RBDuo_Unlock.bin is to unlock these sectors, or the OpenOCD from WICED SDK will failed to erase these sectors. This binary can be found here. After drag and drop this binary via RBLink, then you’ll be able to download WICED application from WICED IDE. But note that after this binary is deployed, the original bootloader is overwritten and not be valid any more.


#3

Hello @guohui

I have loaded the RBDuo_Unlock.bin but I still have the same issue. Downloading WICED aplication from wiced ide only works ONE time after drag & dropping a binary into RBLink folder.

If I don’t use the drag and drop I get the same error. I tried running the Wiced IDE in administrator mode but this didn’t help.

Do you think I need to install openocd seperately? or is there a place in wiced ide where I can check the installation of openocd?

thank you
rifo


#4

Is the on-board single blue LED used in your application? If so, it will also lead the OpenOCD to failure.


#5

oh shoot!

that’s it. Once you try to download an image with on-board blue led, I get the open ocd error and can’t download anything else.

But, with other programs, everything is completely fine.

thanks a lot GuoHui :slight_smile:
rifo

ps: Between, eventhough I don’t use it, the blue led dimly lights. I think with DFU it wasn’t like that. I’ll check and report back on that.


#6

Hello,

I purchased a new batch of redbear duos and will upload them wiced programs. However I can’t unlock and program them :frowning:

I use rblink and drag RBDuo_Unlock.bin, the program is uploaded without problems but it doesn’t start (green light doesn’t blink)

I read a notice on the github webpage but couldn’t figure out what to do?
I am using Wiced SDK 3.7

Can you please guide me about this?


#7

Hi,
Please use this to test the board first.

Unlock the board and then load the RGB test program to see.


#8

hello,

thank you for your answer.

I downloaded the repository (SDK 4.0 branch) from the link you provided and dragged RBDuo_Unlock.bin to RBLink folder (H:) however the green light didn’t start blinking.

I did a power cycle and again particle bootloader started. The code is copied fine but I think that after copy, the program just doesn’t start. Can you please guide me about problem?

thanks


#9

Hello,

Just a side note, I tested other redbear modules that I purchased and the same problem happened.
Can anybody please test this and see if the same problems occurs?

thanks
rifo


#10

We are trying to repeat your problem, once we have any conclusion, we will let you know at once.


#11

Hello Cheong,

Thanks a lot for your help. Looking forward to your response. :thumbsup: :slight_smile:


#12

Hello @cheong

Were you able to repeat the problem? Is there something I can do?

thanks


#13

The RGB test firmware runs as expected on my Duo board. Still not sure what was going wrong with your one.


#14

Can you please attach the RBDuo_Unlock.bin that you are using?

I will just drag this to the RBLink folder that pops out and then I should see the green light blinking right?

If this doesn’t happen in the 15 redbear duos that I purchased, then what should I do?

I know that my Rblink is working fine because I can program other redbear duos that I purhcased before.


#15

Hello,

My time is running short. I have to program the redbear modules and deliver the demo units to the customer.

Can you please attach the RBDuo_Unlock.bin that you used? Did you have the green lights blinking?

I noticed that there was a change in hardware, which version are you using in your trials? The previous redbears that I purhcased don’t have this problem.

The new batch is the problematic ones. (They don’t have the White inductor in the antenna section, see below picture, the redbear on the right is the new batch)


#16

We have updated the patch for WICED SDK 5.0.1

Yes, load the unlock firmware, the RGB should light on Green and flashing very fast.

And then loading the RGB test firmware, the RGB LED should light on R->G->B alternatively.

Would you mind to try the snip.scan and your terminal to see any debug log out there?

Load the snip.scan-RB_DUO.bin_MSD.bin and then use (change tty.usbmodem1413 to your device)
$ screen /dev/tty.usbmodem1413 115200

Sample Output:
Starting WICED v5.0.1
Platform RB_DUO initialised
Started ThreadX v5.6
Initialising NetX_Duo v5.7_sp2
Creating Packet pools
WLAN MAC Address : E0:76:D0:37:8A:6D
WLAN Firmware : wl0: Apr 27 2017 03:30:42 version 7.45.98.18 (r664830) FWID 01-cb1becb6
WLAN CLM : API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.10.39 Inc Compiler: 1.29.4 Inc ClmImport: 1.36.3 Creation: 2017-04-27 03:00:26
Waiting for scan results…

Type BSSID RSSI Rate Chan Security SSID


0 Infra 88:D7:F6:03:77:30 -80 144.4 6 WPA2 AES PSK
1 Infra 8A:10:C8:38:A1:11 -76 216.7 11 WPA2 AES PSK ABC
2 Infra 88:1F:A1:38:C8:10 -60 216.7 11 WPA2 AES PSK ZZZ
3 Infra 54:A0:50:5A:68:80 -70 216.7 11 WPA2 AES PSK YYY
4 Infra D0:03:4B:D7:00:B4 -74 216.7 11 WPA2 AES PSK Home
5 Infra 1E:FE:18:65:10:36 (off-chan)450.0 11 WPA2 AES PSK Guest
6 Infra F8:1A:67:A0:2E:F8 (off-chan)150.0 11 WPA2 AES PSK TP-3019

Scan complete in 497 milliseconds


#17

Nope, it doesn’t work.

I downloaded the repo in the link and then dragged the RBDuo_unlock.bin to RBlink folder. The program is transffered fine but green lights doesn’t start blinking,

(also, when I do a power cycle, I can still see the particle program)

It’s the same with redbear.rgb-RB_DUO.bin_MSD.bin, I dragged it to the RBlink folder, it is transferred fine but no output on the console (com7 in my case)

Note that, as far as I see, RBDuo_unlock.bin did not change in the repository. It’s commit date is 1 year ago.

Please help,


#18

Hi,

Would you mind to use ST-LINK Utility and dump this screen (Option Bytes) for evaluation? Connect your Duo to the RBLink and connect to your PC USB port, runs the ST-LINK Utility to get the screen.

ST-LINK Utility
http://www.st.com/en/embedded-software/stsw-link004.html


#19

Hello,

Sure, I downloaded the program. Below is the screenshot. Sector 11 can’t be seen. It has no protection.


#20

Sorry for your bad experience but please try to erase the entire flash memory using the ST-LINK Utility and then try to drag the unlock.bin to the RBLink drive again.