Updates about IoT pHAT


#1

Hello all,
I wanted to ask if anyone knows exactly what’s going on with the IoT pHAT product? I backed the Kickstarter campaign and received one unit. Testing it initially revealed that there were some issues, specifically it seemed to cause kernel panics during shutdowns. I figured that this was an issue that would be fixed at some point but haven’t come across any updates to that effect in the forums.
I’d really like to know where things stand at the moment. Does the pHAT work with no issues? If there are any issues, what steps need to be taken to solve them and how long until everything is ironed out?

Thanks in advance


#2

@madarax64
I’ve asked this x2 myself and am curious why there has been no “official” response at all for several weeks, not even a “can’t fix it.”


#3

@bpr
I know right? Some closure would be nice. I followed the discussion on GitHub regarding some gpio-power thingy but there’s been nothing since then. Its quite worrisome really


#4

The IoT pHAT needs a GPIO to reset the WiFi when using the “reboot” command, so the gpio-poweroff overlay is used.

However, when using “poweroff” or “halt” command, it (the gpio-poweroff overlay) will cause the kernel panic at the end, there are some discussions in Raspberry Pi forum but no exact answer or solution for this.

Actually, it will not harm your system, also you still need to cut the power manually.

If you really want to shutdown the system gracefully (maybe for your own product):

  1. you need make use of the systemd to drive low to the GPIO pin to WL_REG_ON (pull low to turn off the WiFi).
  2. remove the gpio-overlay in the EEPROM source file,
    https://github.com/redbear/IoT_pHAT/blob/master/eeprom/experimental/v0.3/IoT_pHAT.dts

Any good suggestions are welcome.


#5

Hi all,

An user provided a solution for this and we will provide EEPROM firmware v0.4 for fixing this, stay tuned.


#6

That’s really great news @cheong @bpr . Thank you so much for the update @cheong. If there’s anything we can do to help please let us know.
Anticipating v0.4!


#7

Please follow this to update the EEPROM to v0.4:


#8

@cheong
Definitely works. Thanks a bunch!


#9

Thank you for your testing and report.


#10

so far so good …


#11

@cheong Tested too, working A-OK. Quick question though: is the init_uart_clock fix in config.txt still necessary? Bluetooth seems to work fine without it…

Great job with v0.4!


#12

init_uart_clock will no longer needed with NOOBS 2.0 or above.

Thanks again for your testing.


#13

@cheong Great, thanks. The instructions on GitHub nearly tripped me up there!