WICED Debug


#1

Hello!

I’m trying to use the WICED IDE to develop some projects for RedBear Duo. I’m using the RBLink board and I haven’t any problem downloading apps for example (RGB).

However, I got some errors when I tried to use the GDB debugger.

I used this make target: redbear.rgb-RB_DUO download debug JTAG=RBLINK

The console log is the following:

GNU gdb (GDB) 7.7
Copyright © 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “–host=i686-pc-mingw32 --target=arm-none-eabi”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type “help”.
Type “apropos word” to search for commands related to “word”…
Reading symbols from build/redbear.rgb-RB_DUO/binary/redbear.rgb-RB_DUO.elf…done.
warning: File “C:\Users\sramonta\Documents\WICED\WICED-SDK-3.5.2\WICED-SDK.gdbinit” auto-loading has been declined by your `auto-load safe-path’ set to “$debugdir:$datadir/auto-load”.
To enable execution of this file add
add-auto-load-safe-path C:\Users\sramonta\Documents\WICED\WICED-SDK-3.5.2\WICED-SDK.gdbinit
line to your configuration file “$HOME/.gdbinit”.
To completely disable this security protection add
set auto-load safe-path /
line to your configuration file “$HOME/.gdbinit”.
For more information about this security protection see the
“Auto-loading safe path” section in the GDB manual. E.g., run from the shell:
info “(gdb)Auto-loading safe path”
.gdbinit_attach:1: Error in sourced command file:
localhost:3333: An error occurred during the connection attempt because the connected party did not properly respond after a period of time or there was an error in the connection established because connected host has failed to respond.
(gdb)
Command canceled

And the openOCD_log :

Open On-Chip Debugger 0.9.0-00029-gafd5db2-dirty (2015-05-29-18:47)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : auto-selecting first available session transport “hla_swd”. To override use 'transport select '.
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : Unable to match requested speed 1000 kHz, using 950 kHz
Info : Unable to match requested speed 1000 kHz, using 950 kHz
Info : clock speed 950 kHz
Info : STLINK v2 JTAG v24 API v2 SWIM v11 VID 0x0483 PID 0x374B
Info : using stlink api v2
Info : Target voltage: 3.284210
Info : stm32f2x.cpu: hardware has 6 breakpoints, 4 watchpoints
target state: halted
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0x08000608 msp: 0x2001f0c0
target state: halted
target halted due to breakpoint, current mode: Thread
xPSR: 0x61000000 pc: 0x2000002e msp: 0x2001f0c0
target state: halted
target halted due to breakpoint, current mode: Thread
xPSR: 0x61000000 pc: 0x2000002e msp: 0x2001f0c0
verified 424052 bytes in 3.099000s (133.628 KiB/s)
shutdown command invoked

I’m not able to find the problem, any idea?

Thanks!


Building with WICED SDK
#2

I’m getting this same error. Did you manage to find a fix?


#3

Hi!!

So far I haven’t managed for a solution. I debug using messages through serial port and Putty.

Regards


#4

Not sure what problems you guys are having - I was able to get gdb working with openocd on a Linux Wiley system. If you are using windows I may not be able to help.


#5

Hi @mdelbo @sergio

I am getting same error. and my OS is Windows 10
But you can debug in this way:

  1. Use make tareget :redbear.rgb-RB_DUO download run JTAG=RBLINK
  2. After download, click debug button

    Then It’s work

    After you debug you should kill openOCD process.

I think maybe this error is because of the warning in the console log.

But I don’t know how to solve it.

Jerry


#6

Hi,

I also want to learn how to debug with WICED IDE.

Tried some targets but no luck:

  • redbear.blink-RB_DUO-debug JTAG=RBLINK download run
  • redbear.blink-RB_DUO-debug JTAG=RBLINK download debug
  • redbear.blink-RB_DUO JTAG=RBLINK download run debug

I am using WICED SDK 5.0.1, patch and RBLink. How can I debug with IDE ?


#7

Found https://gnu-mcu-eclipse.github.io/. Tried to test OpenOCD with :

./tools/OpenOCD/Linux64/openocd-all-brcm-libftdi -d1 -f tools/OpenOCD/RBLINK.cfg

And got :

Open On-Chip Debugger 0.10.0-dev-00225-g6bd442a-dirty (2017-03-02-16:54)
Licensed under GNU GPL v2
For bug reports, read
        http://openocd.org/doc/doxygen/bugs.html
debug_level: 1
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Unlock
Error: An adapter speed is not selected in the init script. Insert a call to adapter_khz or jtag_rclk to proceed.

#8

hello @guohui

Can you please help us regarding this issue? I remember a community member posting a guide regarding debugging in eclipse but this doesn’t seem to work now.

It would be very helpful if you can update that guide for us.

thanks a lot
rifo


#9

I‘m afraid I have to say sorry for that, because I’m not an expert on OpenOCD and have less of experience on debug using it. Look forward to someone good at this sharing their experience here!


#10

allright, thanks a lot Guohui


#11

hello riforifo,
I am using WICED 5.0 on Windows 10. I have the redbear duo connected via RBLINK.

I got the WICED debugger to work by doing two things:

  1. Use a make target with this format:
    redbear.scan-RB_DUO-debug JTAG=RBLINK

where “redbear” is my app folder under Apps, and “scan” is just a copy of the scan snip provided with the WICED download.

  1. Next, before you run the debugger, you need to set up the debugger. There is a document on the Cypress WICED forum that shows the proper setup. You can find the document by logging into the WICED Studio Wifi Combo forum, and then click category tag “debug.” The file is provided in a post titled: wiced Debug.

The file is titled: Debugging_WICED,docx

I setup the WICED debugger using these instructions, then executed the above make target, and the build proceeded. Note: I usually have to press the RESET button on my duo to get it to download.
After the build finishes, click the Bug button and the “43xxx_WiFi_Debug Windows” link. The debug will proceed.

I hope RedBear gets their WICED 6.x update out soon.

Jim


#12

Hello Jim

thanks a lot for your response. I have downloaded the document and will give it a try now.